Managed Play Store is empty on devices

Level 2.0: Eclair

We are using Intune to manage our devices and have configured a Managed Goole instance for applications.

Problem is that no apps what so ever is visible in the managed play store on the users devices. When I open the managed play store it just says found no results as if no apps were published.
If I search for lets say Outlook. then I can see the Outlook applicationin the search result. 

Applications that are set to required on devices are installed just fine. Tried several device, both physical and virtual with the same result. Also tried various ways to enroll and administrate the devices

Any tips or suggestions?


Level 4.0: Ice Cream Sandwich

How long did you wait between "deployment" and "check"?
Even we don't use Intune but tested in the past, it was told to us that it may take very long that changes applies on the devices (which was one of the reasons not to go with Intune form our side).

Level 2.0: Eclair

The device I'm currently testing on I enrolled on three days ago. It's been connected to the internet for the whole duration. also done restarts.

OS  and all other apps are up to date

Level 4.0: Ice Cream Sandwich

I see this also. Apps set to required aren't listed, only those set to available show up.

It's been this way for me for the last several years. I don't have an explanation for it at the moment.

Level 2.0: Eclair

Apps listed as required not showing is fine. they install just fine to the device.

But apps listed as available are not listed in the Managed Play Store, but I can see them if I search for them.  Tried the following app types: Managed Google Play Apps, Web Link and Managed Google Play Web Link. none of them are listed

Level 4.0: Ice Cream Sandwich

Issues/behaviours we saw on playstore sometimes (each point independent):
- ensure no updates stuck in the playstore (circle top right > manage apps & device > updates)
- reboot the device once
- wiped playstore data so it needs to collect it again

But i found this (Source) :

In the Assignment tab, If you assign the app to a group under Required, app will be automatically installed on users phone, there is no action required from users end (Note: when using MAM solution, users still have to install the app from app store on iOS or google play store on Android manually). When the app is assigned to a group under Available for enrolled devices, the app will be available for installation via the Company Portal App for enrolled devices and user will have to install the app manually. Last option is to go with Available with or without enrollment.

Official definition of assignments:

RequiredSelect the groups for which you want to make this app required. Required apps are installed automatically on enrolled devices. Some platforms may have additional prompts for the end user to acknowledge before app installation begins.

Available for enrolled devices – Select the groups for which you want to make this app available. Available for enrolled devices apps are displayed in the Company Portal app and website for users to optionally install. Available assignments are only valid for User Groups, not device groups.

Available with or without enrollment – Select the groups for which you want to make this app available with or without enrollment. Apps with this assignment are displayed in the Company Portal app and website for users to optionally install without requiring the device to be enrolled. Available assignments are only valid for User Groups, not device groups.

Level 2.0: Eclair

Downloaded all updates
Deleted all Play Store related data from the device.

But the store remains empty.

The apps set to available are assigned to the All Users Group

Level 4.0: Ice Cream Sandwich

As the article i found showed, did you try to install the Intune Company portal and take a look if the apps are listed there? The description sounds very like that.

Level 2.0: Eclair

The devices are enrolled using the Comapny Portal app. Clicking get apps in company portal opens the Managed Play Store.

I've configured this for several other customers before and never had this issue before

Level 2.0: Eclair

In the past i faced this issue with MobileIron EMM for our BYOD WORK PROFILE : sometime this resolution was helpful to reset the PLAYCATALOG and Reloaded : Troubleshoot common issues - Android Enterprise Help (  If you open the managed Google Play store, and you see a message saying there are no apps to install, it could mean that that your administrator hasn't added any apps yet. However, it can take several hours after an administrator gives access for an app to become available in the managed Google Play store.If after several hours you still can’t see the app in the managed Google Play store, you should delete Play Store data so that it refreshes its cache.

To delete work Play Store data on devices running Android in the enterprise:

  1. Tap Settings 
  2. In the Device section, tap Apps.
  3. From the account menu, select Work Profile.
  4. Scroll to and tap managed Google Play store
  5. Tap Clear Data.
  6. Tap OK and exit Settings.
  7. Open the apps drawer.
  8. Tap managed Google Play store  and accept the terms and conditions.