Error shown when creating a web app

Vasu
Level 1.5: Cupcake

Hi Google Community,

 

I hope this message finds you well. I'm currently experiencing an issue when attempting to create a web application from our EMM (Enterprise Mobility Management) console. The process involves entering a title, URL, and uploading an icon image. Here's what's happening:

  • I have correctly entered the URL, title, and uploaded an icon image that is 512px square and less than 1MB, complying with Google's requirements.
  • However, when I press "Create," I encounter an error message stating: "An error occurred while saving the app. Please ensure that your image is a png or jpg (ideally 512px square) and has a max size of 1MB or smaller.

We've attempted to replicate this issue on a different EMM account and, surprisingly, it works as expected. This leads me to believe that it might be an issue specific to our EMM account or a potential API-related problem.

 

I'm reaching out to the Google Community for insights into what could be causing this issue. If you have experienced a similar problem or have suggestions on how to troubleshoot it, your input would be greatly appreciated.

 

I'm eager to resolve this issue and ensure a smooth experience when creating web applications via our EMM console. Your expertise and guidance will be of tremendous help.

 

Thank you in advance for your assistance!

3 REPLIES 3

Lizzie
Google Community Manager
Google Community Manager

Hello @Vasu,

 

Thanks for your question here. Checking on this.

 

I would first recommend that you reach out to your EMM that is experiencing this issue and indicate that you had tried this in another EMM and was successfully able to upload using the same metadata.
Your EMM's Support team should then be able to check on their back-end through the timestamp on what components could have thrown this error when uploading the app.

 

You can also check under your Android EMM Registration Settings, and run a test connection from there and see the account is still successfully connected to the Android EMM Registration Status, and the Android Management API Registration.

 

As an alternative thing to try, it may be possible that it is a sudden glitch or the EMM may not be detecting the correct size of the icon/image being uploaded. So it's recommended to raise this with your EMM first and let them know it worked as expected using another EMM.

 

Hope this helps, if you can it would be great to hear how this goes. 

 

Thank you,

Lizzie



Welcome to the Community everyone!

Have a question or want to start a conversation, click here.

jasonbayton
Level 3.0: Honeycomb

Logging through the EMM is a good shout, but since this is all in-iframe I'd be surprised if the vendor has too much visibility into the error itself. 

 

Could it be related to the enterprise/bind? Are there any issues handling public or private apps outside of this one @Vasu?

appsplayper2
Level 1.6: Donut

   Answer questions 

1.

That's great! It sounds like you've successfully met Google's requirements for URL, title, and icon image size. Is there anything specific you'd like assistance with or any questions you have regarding this?

2.

It seems like there might be an issue despite meeting the requirements. Double-check that your image is in either PNG or JPG format and exactly 512px square. Also, ensure the file size is below 1MB. If the problem persists, consider refreshing the page or reaching out to Google's support for further assistance.

Mohammad